Redmine redmine “我的工作台”---“指派给我的问题” 提示 “没有任何

chineping@126.com · 2012年11月28日 · 6 次阅读

[i=s] 本帖最后由 chineping 于 2012-11-28 15:01 编辑

RT。 redmine “我的工作台” --- “指派给我的问题” 没有数据,提示 “没有任何数据可显示” 不知道是哪里没有设置对?还是使用不对? 我 googling,没有找到合适解决方法,请问大家在使用 redmine 中是否也遇到类似的问题?能否提供帮忙?

见附件

能否抓个图上来?

1、你需要确定是否有人把任务指向了你 2、你需要在 redmine 配置中,把相关工作台的选项勾选上,注意个人设置相关选项

可能本来就是没有数据,“没有任何数据可显示”

因为根本就没有指派问题给你

能看见图片? 我现在打开 好像是空白 我上传图片,添加附件。

有任务指派给我,见附件中图一。

1、redmine 配置中,我没有找到有关工作台的选项? 相关工作台的选项 是指哪些呢? 2、注意个人设置相关选项 是指哪些选项? 个人设置 是指在 “我的帐号” 的设置么?

对比我的,你看下你的权限设置。

[i=s] 本帖最后由 chineping 于 2012-11-29 09:57 编辑

对比下你的权限设置,我设置成和你的一样,也是没有数据: My page ---》Issues assigned to me (0) ---》No data to display

我也怀疑过权限设置有问题,我将我的账户添加到 管理人员的角色,所有的权限都添加了

你有啥更多发现没?我这里的确没你这个问题。

我被折磨的崩溃了~~~~~

神呀!!!!

方便私信联系么? qq 或 email?

email:[email] chineping@126.com[/email]

昨天终于发现问题的最终原因了!

在 “我的工作台” --- “指派给我的问题” 的查询条件默认是: 状态 : 打开 指派给 : 等于 <<我>>

关键问题所在:新建的 issue 后,该 issue 在查询中的状态怎么变为 “已关闭” 呢? redmine 安装环境是 bitname-redmine-1.4.4,安装时候选择中文、数据库 mysql 安装也是选择中文。

选择中文 语言 安装 redmine/mysql 出现这些悲剧了.

但更悲剧的是,到现在还不明白: 为啥中文安装 redmine/mysql,新建好了的 issue,在查询中的状态自动变为 “已关闭”, 然而使用英文安装 redmine/mysql, 新建好了的 issue, 在查询中的状态是 “打开” 呢?

WHY WHYWHY

过滤器 状态 过滤器
指派给 过滤器

我说的呢,就是根本没有 active issue,所有没有数据。人家的提示是正确的,呵呵。

我用的就是英文版,所以死活也无法重现你说的这个问题。

但更悲剧的是,到现在还不明白: 为啥中文安装 redmine/mysql,新建好了的 issue,在查询中的状态自动变为 “已关闭”, 然而使用英文安装 redmine/mysql, 新建好了的 issue, 在查询中的状态是 “打开” 呢?

为啥呢。。。。。。。。。。。。。 不明白呀!

折腾到半个上午,到现在,一直在将中文版本 redmine 迁移到 重新安装的英文版本 redmine 上 教训呀!!!!

折腾完成!!!!!

还是对 redmine 不熟悉呀!!!!!!! 崩溃! 泪奔。。。。。

找到问题最终原因是:administration ---> Issue statuses 配置时候将 所有的 Status 都是设置为 Issue closed

Status % Done Default value Issue closed Sort
新建 10 [b][color=Red]√ √ [/b]

[i=s] 本帖最后由 chineping 于 2012-11-30 12:04 编辑

.======. |INRI| | | | | .========' '========. | _ xxxx _ | | /;-._ / \ _.-;\ | | -._'_/'.-' | '========.\ /=======' | | / | |/-.( | |_.| | \ `;| | > |/| | / // | | |// | | (\ | | `` | | | | | | | | | \ _ _\| \// |// _ \// _ ^ ^^ ^`^ ^`^^^^^ `^

需要 登录 后方可回复。