DevOps ansible error : to use the 'ssh' connection type with passwords, you must install the sshpass program

laofo · 2017年07月12日 · 最后由 laofo521@gmail.com 回复于 2017年07月12日 · 66 次阅读

ansible error : to use the 'ssh' connection type with passwords, you must install the sshpass program

SSH password:

PLAY [changepasswd] ************************************************************

TASK [setup] *******************************************************************
fatal: [110.94.66.171]: FAILED! => {"failed": true, "msg": "to use the 'ssh' connection type with passwords, you must install the sshpass program"}
    to retry, use: --limit @/home/scmroad/ansible/cmd_deploy_root_pubkey.retry
yum   install -y sshpass
需要 登录 后方可回复。